Grid definitions for diagnostic output

Does anyone know how to make sure that the output fields in fv3_history.nc, and phyfHHH.nc and dynfHHH.nc are on the same grid? I can see that the fv3_history fields are on the ESGgrid and the fields from phyfHHH.nc and dynfHHH.nc are on a lambert_conformal grid. How and where can we define the output grid to ensure they are consistent?

Thanks.

The output grid for phyf* and dynf* is defined in the file model_configure. Removing the part setting "Lambert_conformal" grid in model_configure will make the phyf* and dynf* have the default output grid similar to fv3_history.nc

Thanks!

 

 

Permalink

In reply to by Linlin.Pan

Thanks for the quick reply, LinLin.Pan! I tried what you had suggested, but get the following error message in my 'run_fcst' log:

af allco wrtComp,write_groups=           1

wrt_initialize: Unknown output_grid

wrt_initialize: Unknown output_grid

MPT ERROR: Rank 11(g:11) is aborting with error code 1.

I've attached what my model_configure looks like after the changes.

Attach Files

The variable quilting needs to be set to false, more information can be found at:

https://ufs-weather-model.readthedocs.io/en/ufs-v2.0.0/InputsOutputs.html#output-files

Thanks!

Hi Linlin,

I'm still getting an error and it seems to be coming from the function "create_model_configure_file" (please see below). Would you be able to provide an example model_configure on how the model_configure file should look?

Thanks,
May

ERROR:

  From function:  "create_model_configure_file"

  In file:  "create_model_configure_file.sh"

  Full path to file:  "/path/to/ufs-srweather-app/regional_workflow/ush/create_model_configure_file.sh"

Call to python script fill_jinja_template.py to create a "model_configure"

file from a jinja2 template failed.  Parameters passed to this script are:

  Full path to template rocoto XML file:

    MODEL_CONFIG_TMPL_FP = "/path/to/ufs-srweather-app/regional_workflow/ush/templates/model_configure"

  Full path to output rocoto XML file:

    model_config_fp = "/path/to/exptdir/2019061500/model_configure"

  Namelist settings specified on command line:

    settings =

  'PE_MEMBER01': 12

  'start_year': 2019

  'start_month': 06

  'start_day': 15

  'start_hour': 00

  'nhours_fcst': 1

  'dt_atmos': 300

  'atmos_nthreads': 1

  'ncores_per_node': 36

  'quilting': .false.

  'print_esmf': .false.

  'output_grid':

Exiting with nonzero status.

 

ERROR:

  From script:  "JREGIONAL_RUN_FCST"

  Full path to script:  "/path/to/ufs-srweather-app/regional_workflow/jobs/JREGIONAL_RUN_FCST"

Call to ex-script corresponding to J-job "JREGIONAL_RUN_FCST" failed.

Exiting with nonzero status.

Thanks. Model_configure seems to be created properly now, but I'm now getting error messages from NEMS.exe like the following:

FATAL from PE     0: mpp_domains_define.inc: At least one pe in pelist is not used by any tile in the mosaic

I've attached my model_configure. Thanks.

Attach Files

I can access Hera, Jet, Orion, and Cheyenne. Which machine are you using? I can check that on the listed machines.

Thanks!