How is UPP installed?

I downloaded UPPV11.0.0 with the command "git clone -b upp_v11.0.0 https://github.com/NOAA-EMC/UPP". The file is 44MB. There is no configure script in the parent directory. When I download the gz file on "https://codeload.github.com/NOAA-EMC/UPP/tar.gz/refs/tags/upp_v11.0.0" the file size is 1MB. There is no configure script.

Please help. How does one install. I am used to UPPV4.

Hello!

Sorry for the late response!  I'll check with the development team and get back to you ASAP!

Shawn Cebula

EPIC End User Support

Thanks for waiting.  You may need to use cmake with source and build directories instead of ./configure, if that is how you were using it.  It looks like there were some large changes to how UPP is built between 4.0 and the current 11.0 build.  If you can give that a try and let me know how it goes, that would be great!

Shawn Cebula

EPIC End User Support

Hello Shawn,

Thank you for having looked at my problem.

I tried to install UPPV11.0.0 with the following command

cmake -S /home/zmumba/UPP-upp_v11.0.0 -B . CMAKE_INSTALL_PREFIX=/home/zmumba/UPP-upp_v11.0.0

The message I got is below. I do have bacio-1.3.tar but I have not been able to install it

I will appreciate if you have a cmake command which has worked for UPPV11.0.0

Thank you

Zilore

CMake Error at CMakeLists.txt:47 (find_package):
  By not providing "Findbacio.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "bacio", but
  CMake did not find one.

  Could not find a package configuration file provided by "bacio" with any of
  the following names:

    bacioConfig.cmake
    bacio-config.cmake

  Add the installation prefix of "bacio" to CMAKE_PREFIX_PATH or set
  "bacio_DIR" to a directory containing one of the above files.  If "bacio"
  provides a separate development package or SDK, be sure it has been
  installed.
 

Zilore, 
  
   What system are you running or building the UPP, and what kind of the model or code are using (running, building)? Is it UFS-weather model, SRW App, MRW App?... Are you using any HPC-stack or NCEP libs to build the modules required for the UPP? If yes, which version?

Thank you, and your responses will help to assist you in a most efficient way.
Natalie.
(EPIC-AUS team) 
 

Hello,

I use UPP for graphing WRF-ARW output using grads. I have UPPV4.0 installed and NCEPlibs (I suppose version 1.4.0). UPP is working very well. When I saw that the UPP version has gone as much as V11 I thought of installing the new version. I use gnu compilers on ubuntu 18.04.